Can you see what rule is being triggered so often? I had a similar problem and it ended up being rule 3306 causing the problem. I was basically getting so many emails blocked by zen.spamhaus.org that asl-shun.pl was having a hard time even keeping up with them.
Code:
<rule id="3306" level="6">
<if_sid>3301, 3302</if_sid>
<match> blocked using </match>
<description>IP Address black-listed by anti-spam (blocked).</description>
<group>spam,</group>
</rule>
I followed Scott's suggestion and lowered the level from 6 (block) to 5 (warn only) and that helped tremendously for my situation. I imagine that you could do the same thing with the rule that's causing your problem.