store | blogs | forums | twitter | facebook | wiki | downloads | support portal
Atomic Secure Linux
It is currently Wed Aug 27, 2014 2:55 pm

» Feed - Atomicorp

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: mod_security rpm installation
Unread postPosted: Tue Nov 16, 2010 9:12 am 
Offline
Forum User
Forum User

Joined: Sat Nov 13, 2010 6:52 am
Posts: 33
CENTOS 5.5 x86_64 with cPanel

I am trying to install the atomicorp mod_security module from within WHM software section. I have added the atomic repo, but when I install mod_security from there I get the error that I have pasted at the end of this post.

I have tried doing the thing suggested at the bottom of the error message, but still I get the same problem. Is my servers setup not able to use atomicorp's mod_security package, do I have to use the easy apache installation option instead?


Code:
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * addons: yum.singlehop.com
 * atomic: www3.atomicorp.com
 * base: centos.cs.wisc.edu
 * extras: centos.corenetworks.net
 * updates: mirror.fdcservers.net
Excluding Packages in global exclude list
Finished
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package mod_security.x86_64 0:2.5.11-1.el5.art set to be updated
--> Processing Dependency: httpd-mmn = 20051115 for package: mod_security
--> Processing Dependency: httpd for package: mod_security
--> Processing Dependency: lua for package: mod_security
--> Running transaction check
---> Package lua.x86_64 0:5.1.4-1.el5.art set to be updated
---> Package mod_security.x86_64 0:2.5.11-1.el5.art set to be updated
--> Processing Dependency: httpd-mmn = 20051115 for package: mod_security
--> Processing Dependency: httpd for package: mod_security
--> Finished Dependency Resolution
mod_security-2.5.11-1.el5.art.x86_64 from atomic has depsolving problems
  --> Missing Dependency: httpd-mmn = 20051115 is needed by package mod_security-2.5.11-1.el5.art.x86_64 (atomic)
mod_security-2.5.11-1.el5.art.x86_64 from atomic has depsolving problems
  --> Missing Dependency: httpd is needed by package mod_security-2.5.11-1.el5.art.x86_64 (atomic)
Error: Missing Dependency: httpd is needed by package mod_security-2.5.11-1.el5.art.x86_64 (atomic)
Error: Missing Dependency: httpd-mmn = 20051115 is needed by package mod_security-2.5.11-1.el5.art.x86_64 (atomic)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest


Top
 Profile  
 
 Post subject: Re: mod_security rpm installation
Unread postPosted: Tue Nov 16, 2010 11:21 am 
Offline
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin

Joined: Wed Dec 31, 1969 8:00 pm
Posts: 7888
Location: earth
yes you'll need to use that, since they dont use package management in that environment. I'd also recommend that if you're building from source you add our patches and compile it the same way we do to avoid pcre limits. You can see the spec file here:

http://www4.atomicorp.com/channels/sour ... urity.spec

And grab our patches from the src.rpm here:
http://www4.atomicorp.com/channels/sour ... rt.src.rpm


Top
 Profile  
 
 Post subject: Re: mod_security rpm installation
Unread postPosted: Tue Nov 16, 2010 11:41 am 
Offline
Forum User
Forum User

Joined: Sat Nov 13, 2010 6:52 am
Posts: 33
Thankyou I will try that. I have been trying to install the gotroot rules with the easy apache version of modsec, but cant seem to get them working, I am not sure what I am doing wrong, but am thinking maybe I will have more luck with a different version of mod_sec

As a side note, I previously ran the following command on the system,

wget -q -O - http://www.atomicorp.com/installers/atomic | sh

and am able to view the atomic rpms in WHM yum install rpm list, how do I remove them from the list? Will all of them be unsuitable for this server environment?


Top
 Profile  
 
 Post subject: Re: mod_security rpm installation
Unread postPosted: Tue Nov 16, 2010 12:07 pm 
Offline
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin

Joined: Wed Dec 31, 1969 8:00 pm
Posts: 7888
Location: earth
I'll throw out a "That Depends" there :P Atomic and ASL are designed to integrate with the packages distributed from the vendor (centos/fedora/redhat). Cpanel does integrate with some packages with the vendor, and sometimes they compile their own. Its probably better to ask them which packages you can upgrade safely and which ones you can't with their system.


Top
 Profile  
 
 Post subject: Re: mod_security rpm installation
Unread postPosted: Tue Nov 16, 2010 2:30 pm 
Offline
Forum User
Forum User

Joined: Sat Nov 13, 2010 6:52 am
Posts: 33
Thanks!
Is there a way I can undo what I did when i ran the installer command, to remove the rpms that now show up in the list along with the cpanel ones?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

» Feed - Atomicorp

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: Baidu [Spider] and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group