store | blogs | forums | twitter | facebook | wiki | downloads | support portal
Atomic Secure Linux
It is currently Thu Jul 24, 2014 5:38 pm

» Feed - Atomicorp

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: [atomic] imap sync repo conflict
Unread postPosted: Fri Jan 27, 2012 11:34 pm 
Offline
Forum Regular
Forum Regular

Joined: Sun Mar 29, 2009 6:52 pm
Posts: 350
Hello guys.

I really really need imapsync. But there is a problem. I can't install it cause there is a conflict in the repository. Its been like that for a month unfortunately. I hope you can help. Its really an amazing tool which you can no longer find.

Regards

Code:
# yum install imapsync
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* atomic: www7.atomicorp.com
* base: mirror.softaculous.com
* extras: mirror.softaculous.com
* updates: mirror.softaculous.com
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package imapsync.noarch 0:1.286-1.el5.art set to be updated
--> Processing Dependency: perl(Mail::Box) for package: imapsync
--> Processing Dependency: perl(Mail::IMAPClient) for package: imapsync
--> Processing Dependency: perl(Date::Manip) for package: imapsync
--> Processing Dependency: perl(Term::ReadKey) for package: imapsync
--> Running transaction check
---> Package imapsync.noarch 0:1.286-1.el5.art set to be updated
--> Processing Dependency: perl(Term::ReadKey) for package: imapsync
---> Package perl-DateManip.noarch 0:5.44-1.2.1 set to be updated
---> Package perl-Mail-Box.noarch 0:2.091-1.el5.art set to be updated
--> Processing Dependency: perl(Mail::Transport::Dbx) >= 0.04 for package: perl-Mail-Box
--> Processing Dependency: perl(Text::Autoformat) for package: perl-Mail-Box
--> Processing Dependency: perl(IO::Lines) for package: perl-Mail-Box
--> Processing Dependency: perl(Object::Realize::Later) for package: perl-Mail-Box
--> Processing Dependency: perl(Mail::Internet) for package: perl-Mail-Box
--> Processing Dependency: perl(Email::Simple) for package: perl-Mail-Box
--> Processing Dependency: perl(HTML::TreeBuilder) for package: perl-Mail-Box
--> Processing Dependency: perl(MIME::Parser) for package: perl-Mail-Box
--> Processing Dependency: perl(MIME::Entity) for package: perl-Mail-Box
--> Processing Dependency: perl(MIME::Types) for package: perl-Mail-Box
--> Processing Dependency: perl(Mail::Header) for package: perl-Mail-Box
--> Processing Dependency: perl(File::Remove) for package: perl-Mail-Box
--> Processing Dependency: perl(HTML::FormatText) for package: perl-Mail-Box
--> Processing Dependency: perl(Mail::Address) for package: perl-Mail-Box
---> Package perl-Mail-IMAPClient.noarch 0:3.21-2.el5.art set to be updated
--> Processing Dependency: perl(Parse::RecDescent) for package: perl-Mail-IMAPClient
--> Running transaction check
---> Package imapsync.noarch 0:1.286-1.el5.art set to be updated
--> Processing Dependency: perl(Term::ReadKey) for package: imapsync
---> Package perl-Email-Simple.noarch 0:1.999-2.el5.art set to be updated
---> Package perl-File-Remove.noarch 0:0.38-1.el5.art set to be updated
---> Package perl-HTML-Format.noarch 0:2.04-6.el5.art set to be updated
--> Processing Dependency: perl(Font::Metrics::HelveticaOblique) for package: perl-HTML-Format
--> Processing Dependency: perl(Font::Metrics::TimesBoldItalic) for package: perl-HTML-Format
--> Processing Dependency: perl(Font::Metrics::CourierBoldOblique) for package: perl-HTML-Format
--> Processing Dependency: perl(Font::Metrics::CourierBold) for package: perl-HTML-Format
--> Processing Dependency: perl(Font::Metrics::TimesBold) for package: perl-HTML-Format
--> Processing Dependency: perl(Font::Metrics::TimesItalic) for package: perl-HTML-Format
--> Processing Dependency: perl(Font::Metrics::CourierOblique) for package: perl-HTML-Format
--> Processing Dependency: perl(Font::Metrics::HelveticaBoldOblique) for package: perl-HTML-Format
--> Processing Dependency: perl(Font::Metrics::HelveticaBold) for package: perl-HTML-Format
--> Processing Dependency: perl(Font::Metrics::Helvetica) for package: perl-HTML-Format
--> Processing Dependency: perl(Font::Metrics::TimesRoman) for package: perl-HTML-Format
--> Processing Dependency: perl(Font::Metrics::Courier) for package: perl-HTML-Format
---> Package perl-HTML-Tree.noarch 1:3.23-9.el5.art set to be updated
---> Package perl-IO-stringy.noarch 0:2.110-5.el5.art set to be updated
---> Package perl-MIME-Types.noarch 0:1.28-2.el5.art set to be updated
---> Package perl-MIME-tools.noarch 0:5.420-3.el5.art set to be updated
--> Processing Dependency: perl(Convert::BinHex) for package: perl-MIME-tools
---> Package perl-Mail-Transport-Dbx.x86_64 0:0.07-3.el5.art set to be updated
---> Package perl-MailTools.noarch 0:1.77-1.el5.centos set to be updated
---> Package perl-Object-Realize-Later.noarch 0:0.16-1.el5.art set to be updated
---> Package perl-Parse-RecDescent.noarch 0:1.962.2-1.el5.art set to be updated
--> Processing Dependency: perl(version) for package: perl-Parse-RecDescent
---> Package perl-Text-Autoformat.noarch 0:1.13-5.el5.art set to be updated
--> Processing Dependency: perl(Text::Reform) for package: perl-Text-Autoformat
--> Running transaction check
---> Package imapsync.noarch 0:1.286-1.el5.art set to be updated
--> Processing Dependency: perl(Term::ReadKey) for package: imapsync
---> Package perl-Convert-BinHex.noarch 0:1.119-5.el5.art set to be updated
---> Package perl-Font-AFM.noarch 0:1.19-4.el5.art set to be updated
---> Package perl-Text-Reform.noarch 0:1.11-6.el5.art set to be updated
--> Processing Dependency: perl(TeX::Hyphen) for package: perl-Text-Reform
---> Package perl-version.x86_64 1:0.7203-2.el5.art set to be updated
--> Running transaction check
---> Package imapsync.noarch 0:1.286-1.el5.art set to be updated
--> Processing Dependency: perl(Term::ReadKey) for package: imapsync
---> Package perl-TeX-Hyphen.noarch 0:0.140-5.el5.art set to be updated
--> Finished Dependency Resolution
imapsync-1.286-1.el5.art.noarch from atomic has depsolving problems
--> Missing Dependency: perl(Term::ReadKey) is needed by package imapsync-1.286-1.el5.art.noarch (atomic)
Error: Missing Dependency: perl(Term::ReadKey) is needed by package imapsync-1.286-1.el5.art.noarch (atomic)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest

_________________
Hello IT.
Phone : Blah Blah ....
Have you tried turning it on and off again ?
Phone : Blah Blah ....
....
I'm sorry, are you from the Past ?!
http://www.youtube.com/watch?v=-E4fm4Wqego


Top
 Profile  
 
 Post subject: Re: [atomic] imap sync repo conflict
Unread postPosted: Sat Jan 28, 2012 5:49 am 
Offline
Forum Regular
Forum Regular

Joined: Sat Mar 28, 2009 6:58 pm
Posts: 851
Location: Germany
Don't know if it helps but what about this:
http://pkgs.repoforge.org/imapsync/


Top
 Profile  
 
 Post subject: Re: [atomic] imap sync repo conflict
Unread postPosted: Sat Jan 28, 2012 7:41 am 
Offline
Forum Regular
Forum Regular

Joined: Sun Mar 29, 2009 6:52 pm
Posts: 350
Hi there. Thanks for the reply.
I see. If I install an rpm is there a possibility this might somehow affect the packages installed or yum functionality ?
Also would you recommend some specific flags for installation of the rpm ?

_________________
Hello IT.
Phone : Blah Blah ....
Have you tried turning it on and off again ?
Phone : Blah Blah ....
....
I'm sorry, are you from the Past ?!
http://www.youtube.com/watch?v=-E4fm4Wqego


Top
 Profile  
 
 Post subject: Re: [atomic] imap sync repo conflict
Unread postPosted: Sat Jan 28, 2012 8:39 am 
Offline
Forum Regular
Forum Regular

Joined: Sat Mar 28, 2009 6:58 pm
Posts: 851
Location: Germany
yes.
the most simple way to make sure is adding this repo on your box. take a look at this:
http://wiki.centos.org/AdditionalResour ... s/RPMForge
and than install imapsync via yum like always.
than you will see if dependeny problem might occur.
afterwards i would disable this repo and enable it only if you need something out of it.


Top
 Profile  
 
 Post subject: Re: [atomic] imap sync repo conflict
Unread postPosted: Sat Jan 28, 2012 11:57 am 
Offline
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin

Joined: Wed Dec 31, 1969 8:00 pm
Posts: 7863
Location: earth
Id use the epel repo for those other perl dependencies. Thats what its being built against.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

» Feed - Atomicorp

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group