store | blogs | forums | twitter | facebook | wiki | downloads | support portal
Atomic Secure Linux
It is currently Sat Oct 25, 2014 6:04 pm

» Feed - Atomicorp

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 7 posts ] 
Author Message
 Post subject: Plesk 10.2 on CentOS / yum install qmail-scanner fails
Unread postPosted: Sat Jun 18, 2011 2:22 pm 
Offline
New Forum User
New Forum User

Joined: Sat Jun 18, 2011 2:13 pm
Posts: 4
Location: Germany
Hi,

I wanted to install qmail-scanner on my CentOS 5 machine, but it fails with the following error.
I removed all drweb packages from my machine also, like suggested on this site http://www.grafxsoftware.com/faq.php/HOW-TO-Setup-a-PLESK-Dedicated-Server/1/4/ (Point/Item 8. ANTIVIRUS:), but still no success.

Code:
yum install qmail-scanner
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * atomic: www7.atomicorp.com
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package qmail-scanner.x86_64 1:2.08-5.el5.art set to be updated
--> Processing Dependency: daemontools >= 0.76 for package: qmail-scanner
--> Processing Dependency: maildrop for package: qmail-scanner
--> Processing Dependency: tnef for package: qmail-scanner
--> Processing Dependency: qmail for package: qmail-scanner
--> Processing Dependency: perl-suidperl for package: qmail-scanner
--> Running transaction check
---> Package daemontools.x86_64 0:0.76-1.el5.art set to be updated
---> Package maildrop.x86_64 0:2.5.2-1.el5.art set to be updated
---> Package perl-suidperl.x86_64 4:5.8.8-32.el5_6.3 set to be updated
---> Package qmail.x86_64 4:1.03-32.2.el4.art set to be updated
--> Processing Dependency: supervise-scripts >= 3.2 for package: qmail
--> Processing Dependency: ucspi-tcp >= 0.86-1 for package: qmail
--> Processing Dependency: ucspi-unix for package: qmail
---> Package tnef.x86_64 0:1.4.5-1.el5.art set to be updated
--> Running transaction check
---> Package supervise-scripts.noarch 0:3.5-2.el5.art set to be updated
---> Package ucspi-tcp.x86_64 0:0.88-5.el5.art set to be updated
---> Package ucspi-unix.x86_64 0:0.36-1.el5.art set to be updated
--> Processing Conflict: qmail conflicts psa
--> Finished Dependency Resolution
4:qmail-1.03-32.2.el4.art.x86_64 from atomic has depsolving problems
  --> qmail conflicts with psa
Error: qmail conflicts with psa
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest


Anyone can help me with that?


Top
 Profile  
 
 Post subject: Re: Plesk 10.2 on CentOS / yum install qmail-scanner fails
Unread postPosted: Sun Jun 19, 2011 5:15 am 
Offline
Long Time Forum Regular
Long Time Forum Regular

Joined: Sat Aug 20, 2005 9:30 am
Posts: 2812
Location: The Netherlands
If I read that output correctly you have a qmail.x86_64 el4.art package installed. Is that correct? That seems strange to me. First: you should have a psa-qmail package instead of a package called qmail on Plesk and el4 on a CentOS 5 system also sounds wrong.

What does rpm -qa | grep -i qmail say?

_________________
Lemonbit Internet Dedicated Server Management


Top
 Profile  
 
 Post subject: Re: Plesk 10.2 on CentOS / yum install qmail-scanner fails
Unread postPosted: Sun Jun 19, 2011 10:39 am 
Offline
New Forum User
New Forum User

Joined: Sat Jun 18, 2011 2:13 pm
Posts: 4
Location: Germany
Hmm...the command doesn't print anything. So I tried "locate -i qmail", which prints the following:

Code:
/usr/lib/mailman/.qmail
/usr/lib/mailman/Mailman/Bouncers/Qmail.py
/usr/lib/mailman/Mailman/Bouncers/Qmail.pyc
/usr/lib/mailman/Mailman/Bouncers/Qmail.pyo
/usr/lib/mailman/tests/bounces/qmail_01.txt
/usr/lib/mailman/tests/bounces/qmail_02.txt
/usr/lib/mailman/tests/bounces/qmail_03.txt
/usr/local/psa/PMM/agents/shared/QmailAgent.pm
/usr/share/doc/mailman-2.1.9/admin/www/mailman-install/qmail-issues.html
/usr/share/doc/mailman-2.1.9/contrib/qmail-to-mailman.py
/usr/share/doc/mailman-2.1.9/contrib/qmail-to-mailman.pyc
/usr/share/doc/mailman-2.1.9/contrib/qmail-to-mailman.pyo
/var/qmail
/var/drweb/.qmail
/var/qmail/.pyzor
/var/qmail/.razor
/var/qmail/mailnames
/var/qmail/popuser
/var/qmail/.pyzor/servers
/var/qmail/.razor/server.c301.cloudmark.com.conf
/var/qmail/.razor/servers.catalogue.lst
/var/qmail/.razor/servers.discovery.lst
/var/qmail/.razor/servers.nomination.lst
/var/qmail/mailnames/.spamtrain
/var/qmail/mailnames/[mydomain]
/var/qmail/mailnames/.spamtrain/last_update


and "rpm -qa | grep -i psa" prints this:

Code:
psa-pylibplesk-10.11.0-cos5.build1011110331.11
psa-locale-base-en-US-10.11.0-cos5.build1011110328.18
psa-mail-driver-common-10.11.0-cos5.build1011110331.11
psa-awstats-configurator-10.11.0-cos5.build1011110330.18
psa-mod-fcgid-configurator-2.0.0-cos5.build1011110330.18
psa-migration-manager-10.11.0-cos5.build1011110331.11
psa-rubyrails-configurator-1.1.6-cos5.build1011110330.18
psa-vpn-10.11.0-cos5.build1011110331.11
psa-horde-3.3.10-cos5.build1011110330.18
psa-mimp-1.1.3-cos5.build1011101207.12
psa-selinux-10.11.0-cos5.build1011110331.11
psa-php5-configurator-1.6.1-cos5.build1011110330.18
psa-vhost-10.11.0-cos5.build1011110330.18
psa-updates-10.2.0-cos5.build1011110330.18
psa-migration-agents-10.11.0-cos5.build1011110331.11
psa-fileserver-10.11.0-cos5.build1011110331.11
psa-mailman-configurator-10.11.0-cos5.build1011110331.11
psa-imp-4.3.9-cos5.build1011110330.18
psa-mnemo-2.2.4-cos5.build1011110330.18
psa-coldfusion-support-10.11.0-cos5.build1011101207.12
psa-triggers-10.11.0-cos5.build1011110511.09
psa-spf2-1.2.9-10120712
psa-10.2.0-cos5.build1011110331.11
psa-autoinstaller-3.9.0-110316.15
psa-ftputil-2.1.1-1.10120712
psa-miva-5.06-cos5.build1011110330.18
psa-watchdog-10.11.0-cos5.build1011110331.11
psa-atis-1.1-50
psa-ingo-1.2.5-cos5.build1011110330.18
psa-passwd-3.1.3-cos5.build1011110330.18
psa-mod_jk-1.2.31-10120712
psa-tomcat-configurator-10.11.0-cos5.build1011110330.18
psa-proftpd-1.3.3d-1.el5.art
psa-logrotate-3.7-cos5.build1011110330.18
psa-libpam-plesk-10.11.0-cos5.build1011110331.11
psa-courier-imap-3.0.8-cos5.build1011110330.18
psa-mod_fcgid-2.3.5-11021819
psa-backup-manager-10.11.0-cos5.build1011110331.11
psa-fcgi-2.4.0-2
psa-firewall-10.11.0-cos5.build1011110331.11
psa-kav8-8.0.3-0.296040
psa-pear-1.9.1-20100810.10120712
psa-kronolith-2.3.5-cos5.build1011110330.18
psa-turba-2.3.5-cos5.build1011110330.18


Top
 Profile  
 
 Post subject: Re: Plesk 10.2 on CentOS / yum install qmail-scanner fails
Unread postPosted: Sun Jun 19, 2011 4:51 pm 
Offline
Long Time Forum Regular
Long Time Forum Regular

Joined: Sat Aug 20, 2005 9:30 am
Posts: 2812
Location: The Netherlands
It doesn't look like you currently have qmail installed. Maybe you're using postfix with Plesk?

I don't know where yum would want to get that qmail package for el4. Do you have a yum configuration for the el4 version of the atomic repository?

_________________
Lemonbit Internet Dedicated Server Management


Top
 Profile  
 
 Post subject: Re: Plesk 10.2 on CentOS / yum install qmail-scanner fails
Unread postPosted: Mon Jun 20, 2011 4:47 am 
Offline
New Forum User
New Forum User

Joined: Sat Jun 18, 2011 2:13 pm
Posts: 4
Location: Germany
oh my god!! sorry man, my fault. I got postfix on the machine...
It's my first server and I am new to linux, so thank you for you help anyway.
I'm going to skip this step and install mailscanner...


Top
 Profile  
 
 Post subject: Re: Plesk 10.2 on CentOS / yum install qmail-scanner fails
Unread postPosted: Mon Jun 20, 2011 8:58 am 
Offline
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin

Joined: Wed Dec 31, 1969 8:00 pm
Posts: 7943
Location: earth
The equivalent of qmail-scanner for postfix is clapf (yum install clapf)


Top
 Profile  
 
 Post subject: Re: Plesk 10.2 on CentOS / yum install qmail-scanner fails
Unread postPosted: Mon Jun 20, 2011 9:18 am 
Offline
New Forum User
New Forum User

Joined: Sat Jun 18, 2011 2:13 pm
Posts: 4
Location: Germany
yeah, you are right. I saw it on the HOW-TO page which I posted...thank you anyway scott


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

» Feed - Atomicorp

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: Bing [Bot] and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group