I haven't received a reply on this and the issue is growing on my end. I have a dedicated server customer that insists on bleeding edge or close to it.
Not quite bleeding edge she wants Zend 3.3.3 which apparently has been installed as an upgrade before on her old server but PHP was not upgraded.
Now Plesk 10.4.4 (a pain in the a$$!!!!!!!! for migrations) releases PHP 5.3.3 and Zend 2.3.0
[root@abbey ~]# php -v
PHP Warning: Directive 'safe_mode' is deprecated in PHP 5.3 and greater in Unknown on line 0
PHP 5.3.3 (cli) (built: May 7 2012 20:13:47)
Copyright (c) 1997-2010 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
with the ionCube PHP Loader v4.0.7, Copyright (c) 2002-2011, by ionCube Ltd.
I simply cannot understand the logic behind Parallels. It makes no sense to install such an outdated version of php.
Complicating matters if one installs the Atomic repo Plesk complains that using it may be hazardous to one's server health. I am not an advanced server admin and don't have the ability to recover if all heck breaks loss.
So then how do I upgrade to PHP 5.3.16 and Zend 3.3.3 without breaking Plesk 10.4.4? It has to get done but I have yet to find instructions on doing it. Plesk will go as far now as refusing support if a non-approved repo is used (aka Atomic) Been there, done that. I've fought with them all week. With cleqar instructions however, I'd do it anyway.
Could someone please help a man struggling to keep up with changes that seem to happen every week? PLEASE?