store | blogs | forums | twitter | facebook | wiki | downloads | support portal
Atomic Secure Linux
It is currently Tue Sep 16, 2014 1:26 pm

» Feed - Atomicorp

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 9 posts ] 
Author Message
 Post subject: Updating PHP - php-pear dependancy problems?
Unread postPosted: Wed May 28, 2008 8:34 pm 
Offline
New Forum User
New Forum User

Joined: Wed May 28, 2008 8:30 pm
Posts: 4
Hello! First off, thanks to scott for his work in giving us plesk users hope at upgrading.. well anything successfully!

I've got an older FC4 system running plesk 8.2 (was 8.1), I'm moving to a newer system in a few months, but I need to update PHP on this system before the move.

I've setup the channel, however I'm getting weird issues trying to update.

Code:
Error: Missing Dependency: php = 5.0.4-10.5 is needed by package php-pear
Error: Missing Dependency: php-common = 5.2.5-2.fc4.art is needed by package php-pdo


I can't remove it, I can't update it.. it's got me kinda stuck. I'm not terribly new to Linux but at the same time I'm not comfortable ripping things out by the lower extremeties without asking for help first.

My php version is 5.0.4, I'm just trying to get something a bit newer because I'm having some compatibility issues with various php apps.

Thanks in advance for any help that can be provided!

X


Top
 Profile  
 
 Post subject:
Unread postPosted: Wed May 28, 2008 8:46 pm 
Offline
New Forum User
New Forum User

Joined: Wed May 28, 2008 8:30 pm
Posts: 4
Actually, I think managing the pear conflict is the least of my worries for the moment. I ran through the procedure again and noticed this error at the end of yum update.

Code:
--> Processing Conflict: psa-selinux conflicts policycoreutils < 1.27.2-1.2
--> Finished Dependency Resolution
Error: psa-selinux conflicts with policycoreutils < 1.27.2-1.2
Error: Missing Dependency: net-snmp = 5.2.1-12 is needed by package net-snmp-libs


I've never used yum on this system before now, always the updater within plesk CP.


Top
 Profile  
 
 Post subject:
Unread postPosted: Wed May 28, 2008 9:42 pm 
Offline
New Forum User
New Forum User

Joined: Wed May 28, 2008 8:30 pm
Posts: 4
Okay.. Some progress, I resolved the basic psa-selinux and policycoreutils issues.

I should point out, the system still runs MySQL 4.1.

When I run yum update, it downloads 50 packages and updates 120. Once I continue, it runs a Transaction test which spits out a ton of mysql errors (and a few regarding some man pages) then stops.

I have no immediate need to update to MySQL5, as I know the new system will come with it. Here's a small snippet of the errors.

Code:
 file /usr/share/man/man1/mysqldump.1.gz from install of mysql-5.0.51-1.fc4.art conflicts with file from package mysql-4.1.11-2
  file /usr/share/man/man1/mysqlshow.1.gz from install of mysql-5.0.51-1.fc4.art conflicts with file from package mysql-4.1.11-2
  file /usr/bin/msql2mysql from install of mysql-5.0.51-1.fc4.art conflicts with file from package mysql-4.1.20-1.FC4.1
  file /usr/bin/mysql_find_rows from install of mysql-5.0.51-1.fc4.art conflicts with file from package mysql-4.1.20-1.FC4.1
  file /usr/bin/mysql_tableinfo from install of mysql-5.0.51-1.fc4.art conflicts with file from package mysql-4.1.20-1.FC4.1
  file /usr/bin/mysqlaccess from install of mysql-5.0.51-1.fc4.art conflicts with file from package mysql-4.1.20-1.FC4.1
  file /usr/share/info/mysql.info.gz from install of mysql-5.0.51-1.fc4.art conflicts with file from package mysql-4.1.20-1.FC4.1
  file /usr/share/man/man1/mysql.1.gz from install of mysql-5.0.51-1.fc4.art conflicts with file from package mysql-4.1.20-1.FC4.1
  file /usr/share/man/man1/mysqlaccess.1.gz from install of mysql-5.0.51-1.fc4.art conflicts with file from package mysql-4.1.20-1.FC4.1
  file /usr/share/man/man1/mysqladmin.1.gz from install of mysql-5.0.51-1.fc4.art conflicts with file from package mysql-4.1.20-1.FC4.1
  file /usr/share/man/man1/mysqldump.1.gz from install of mysql-5.0.51-1.fc4.art conflicts with file from package mysql-4.1.20-1.FC4.1
  file /usr/share/man/man1/mysqlshow.1.gz from install of mysql-5.0.51-1.fc4.art conflicts with file from package mysql-4.1.20-1.FC4.1


If I simply try to just yum update php - I receive the following.

Code:
--> Processing Dependency: php-common = 5.2.5-2.fc4.art for package: php-pdo
--> Finished Dependency Resolution
Error: Missing Dependency: php-common = 5.2.5-2.fc4.art is needed by package php-pdo


Is this a losing battle?


Top
 Profile  
 
 Post subject:
Unread postPosted: Wed May 28, 2008 11:46 pm 
Offline
New Forum User
New Forum User

Joined: Wed May 28, 2008 8:30 pm
Posts: 4
Please just delete this thread, there's so many things wrong with this old box it's not worth fixing! Just gonna migrate to a newer one in a day or two instead of a few months. Better use of time :)


Top
 Profile  
 
 Post subject:
Unread postPosted: Thu May 29, 2008 8:19 am 
Offline
Forum Regular
Forum Regular

Joined: Mon Apr 10, 2006 12:55 pm
Posts: 672
You may need to update php-pear by itself before you can update PHP. See if that fixes it.


Top
 Profile  
 
 Post subject:
Unread postPosted: Thu Jun 12, 2008 1:01 pm 
Offline
Forum Regular
Forum Regular

Joined: Mon Nov 28, 2005 4:44 pm
Posts: 119
How do you do this? Because I'm in the same boat. Putting 'yum update php-pear' results in nothing.

Putting in yum update php gives:

Code:
Error: Missing Dependency: php = 4.3.9-3.22.9 is needed by package php-pear
Error: Missing Dependency: php-common = 5.2.5-4.el4.art is needed by package php-xml


I have both stable and testing repos enabled.


Top
 Profile  
 
 Post subject:
Unread postPosted: Fri Jun 13, 2008 8:26 am 
Offline
Forum Regular
Forum Regular

Joined: Mon Apr 10, 2006 12:55 pm
Posts: 672
Try
Code:
#yum install php-pear

Instead of upgrading.


Top
 Profile  
 
 Post subject:
Unread postPosted: Fri Jun 13, 2008 6:32 pm 
Offline
Forum Regular
Forum Regular

Joined: Mon Nov 28, 2005 4:44 pm
Posts: 119
# yum install php-pear
Code:
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package php-pear.x86_64 0:4.3.9-3.22.9 set to be updated
--> Running transaction check
--> Processing Dependency: php = 4.3.9-3.22.9 for package: php-pear
--> Finished Dependency Resolution
Error: Missing Dependency: php = 4.3.9-3.22.9 is needed by package php-pear


Top
 Profile  
 
 Post subject:
Unread postPosted: Fri Jun 13, 2008 7:56 pm 
Offline
Forum Regular
Forum Regular

Joined: Mon Nov 28, 2005 4:44 pm
Posts: 119
Well, I fixed it. In a roundabout way.

I forced erased php and all it's extensions through RPM, then I installed php-pear first, then I installed php-domxml, then the rest of PHP. Now it stopped complaining.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 

» Feed - Atomicorp

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group