store | blogs | forums | twitter | facebook | wiki | downloads | support portal
Atomic Secure Linux
It is currently Tue Sep 02, 2014 10:04 pm

» Feed - Atomicorp

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 9 posts ] 
Author Message
 Post subject: (SOLVED) - ExponentCMS - Fatal error: Class editorcontrol
Unread postPosted: Thu Aug 14, 2008 2:06 am 
Offline
Forum Regular
Forum Regular

Joined: Tue Jul 15, 2008 2:38 pm
Posts: 770
Location: Sweden
I am having trouble with a customers CMS installation after installing ASL. Some modules, especially the editor module, doesn't show up anymore. When I turn on the debugging I get the following error Fatal error: Class editorcontrol: Cannot inherit from undefined class formcontrol in /var/www/vhosts/domain.com/httpdocs/subsystems/forms/controls/EditorControl.php on line 34 I realize this is moreof a ExponentCMS question but as it started when I installed ASL I thought I should ask you as well.

Anyone got any suggestions?


Last edited by biggles on Wed Aug 20, 2008 3:51 am, edited 1 time in total.

Top
 Profile  
 
 Post subject:
Unread postPosted: Thu Aug 14, 2008 5:01 am 
Offline
Long Time Forum Regular
Long Time Forum Regular

Joined: Sat Aug 20, 2005 9:30 am
Posts: 2812
Location: The Netherlands
Do you see related block events in the ASL web interface?

_________________
Lemonbit Internet Dedicated Server Management


Top
 Profile  
 
 Post subject:
Unread postPosted: Thu Aug 14, 2008 5:04 am 
Offline
Forum Regular
Forum Regular

Joined: Tue Jul 15, 2008 2:38 pm
Posts: 770
Location: Sweden
Nope...


Top
 Profile  
 
 Post subject:
Unread postPosted: Thu Aug 14, 2008 5:27 am 
Offline
Long Time Forum Regular
Long Time Forum Regular

Joined: Sat Aug 20, 2005 9:30 am
Posts: 2812
Location: The Netherlands
It doesn't sound like an ASL-related problem so far.

_________________
Lemonbit Internet Dedicated Server Management


Top
 Profile  
 
 Post subject:
Unread postPosted: Thu Aug 14, 2008 7:17 am 
Offline
Forum Regular
Forum Regular

Joined: Tue Jul 15, 2008 2:38 pm
Posts: 770
Location: Sweden
OK, thanks for your effort!

I cannot see how it could have started any other way though. PHP gets locked down quite a bit when you install ASL as far as I can tell. I cannot really find what all the PHP options means so I am having a hard time finding what is causing the problem...


Top
 Profile  
 
 Post subject:
Unread postPosted: Thu Aug 14, 2008 7:27 am 
Offline
Long Time Forum Regular
Long Time Forum Regular

Joined: Sat Aug 20, 2005 9:30 am
Posts: 2812
Location: The Netherlands
They are all documented on the PHP site. Have you checked the file and line number mentioned in the error message? You could also try enabling any disabled PHP functions and see if that gets it back to life.

_________________
Lemonbit Internet Dedicated Server Management


Top
 Profile  
 
 Post subject:
Unread postPosted: Thu Aug 14, 2008 3:44 pm 
Offline
Forum Regular
Forum Regular

Joined: Tue Jul 15, 2008 2:38 pm
Posts: 770
Location: Sweden
Yeah, but there are quite a lot of functions and the names doesn't give much clues. "allow_exec"? Which php site did you mean? php.net?


Top
 Profile  
 
 Post subject:
Unread postPosted: Thu Aug 14, 2008 4:13 pm 
Offline
Long Time Forum Regular
Long Time Forum Regular

Joined: Sat Aug 20, 2005 9:30 am
Posts: 2812
Location: The Netherlands
Yes, php.net. Have you checked the domain's error_log? Does that tell you the code is trying to use a disabled function? Or maybe there really is a problem with the code (class formcontrol not being defined).

_________________
Lemonbit Internet Dedicated Server Management


Top
 Profile  
 
 Post subject:
Unread postPosted: Wed Aug 20, 2008 3:51 am 
Offline
Forum Regular
Forum Regular

Joined: Tue Jul 15, 2008 2:38 pm
Posts: 770
Location: Sweden
OK, fixed the problem! It seemed like the attack that made me install ASL had manipulated some files installed by Exponent. When I re-installed Exponent over the old installation everything got fixed!

Thanks for your help and suggestions!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 

» Feed - Atomicorp

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group