store | blogs | forums | twitter | facebook | wiki | downloads | support portal
Atomic Secure Linux
It is currently Sun Sep 21, 2014 12:02 am

» Feed - Atomicorp

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 7 posts ] 
Author Message
 Post subject: Installing php 5.2.x with ART - RHEL5 Plesk 8.2
Unread postPosted: Thu Jan 29, 2009 2:18 pm 
Offline
New Forum User
New Forum User

Joined: Thu Jan 29, 2009 2:13 pm
Posts: 3
Hi Everyone!

I was curious if someone could point me in the right direction. I am a little overwhelmed by the content on the site.

WHAT I WANT:
I want to upgrade my version of php from: 5.1.6-20.el5_2.1
to 5.2.x

WHAT I HAVE:
I have a RHEL5 server running plesk:
psa v8.2.0_build82070807.17 os_RedHat el5

If someone could simply point me in the right direction. I'm not the best at ssh but I can fumble around ok. Thanks so much in advance!


Top
 Profile  
 
 Post subject:
Unread postPosted: Thu Jan 29, 2009 5:24 pm 
Offline
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin

Joined: Wed Dec 31, 1969 8:00 pm
Posts: 7901
Location: earth
Sure got a wiki page for it here:

http://www.atomicorp.com/wiki/index.php/PHP


Top
 Profile  
 
 Post subject:
Unread postPosted: Fri Jan 30, 2009 4:12 am 
Offline
New Forum User
New Forum User

Joined: Thu Jan 29, 2009 2:13 pm
Posts: 3
Thanks!

Well, I tried it... But it seems as though I have some errors and need some help if possible. It seemed like I was missing some files during the yum update.

Code:
[root@joshua freshapps.com]# yum update
Loading "rhnplugin" plugin
Loading "security" plugin
plesk                     100% |=========================|  951 B    00:00     
primary.xml.gz            100% |=========================|  75 kB    00:00     
plesk     : ################################################## 193/193
rhn-tools-rhel-i386-serve 100% |=========================| 1.2 kB    00:00     
rhel-i386-server-5        100% |=========================| 1.3 kB    00:00     
atomic                    100% |=========================|  951 B    00:00     
primary.xml.gz            100% |=========================| 118 kB    00:00     
atomic    : ################################################## 338/338
rhel-i386-server-vt-5     100% |=========================| 1.3 kB    00:00     
Skipping security plugin, no data
Setting up Update Process
Resolving Dependencies
Skipping security plugin, no data
--> Running transaction check
---> Package stunnel.i386 0:4.15-2.el5.1 set to be updated
---> Package xorg-x11-drv-mutouch.i386 0:1.1.0-3 set to be updated
---> Package oprofile.i386 0:0.9.3-18.el5 set to be updated
---> Package psa-updates.noarch 0:8.6.0-cos5.build86080930.08 set to be updated
--> Processing Dependency: psa-hotfix5-8.6.0 = 8.6.0-cos5.build86080930.08 for package: psa-updates
--> Processing Dependency: plesk-skins = 8.6.0 for package: psa-updates
---> Package mesa-libGL.i386 0:6.5.1-7.7.el5 set to be updated
---> Package cdrecord.i386 9:2.01-10.7.el5 set to be updated
---> Package psa-appvault-mediawiki.noarch 0:1.11.0-8200920080409011142 set to be updated
---> Package pfmon.i386 0:3.2-0.060926.5.el5 set to be updated
---> Package psa-locale-zh-TW.noarch 0:8.6-build86080716.14 set to be updated
---> Package hwdata.noarch 0:0.213.11-1.el5 set to be updated
---> Package psa-appvault-b2evolution.noarch 0:0.9.0.12-8203020080409005439 set to be updated
---> Package php-xml.i386 0:5.2.8-3.el5.art set to be updated
---> Package dhclient.i386 12:3.0.5-18.el5 set to be updated
--> Processing Dependency: psa-security = 8.2 for package: psa-fileserver
--> Processing Dependency: psa-security = 8.2 for package: cs-gs
--> Processing Dependency: psa-security = 8.2 for package: psa-firewall
--> Processing Dependency: psa-security = 8.2 for package: psa-vpn
---> Package php-mbstring.i386 0:5.2.8-3.el5.art set to be updated
---> Package OpenIPMI.i386 0:2.0.6-11.el5 set to be updated
---> Package dbus-x11.i386 0:1.1.2-12.el5 set to be updated
---> Package gcc.i386 0:4.1.2-44.el5 set to be updated
---> Package kudzu-devel.i386 0:1.2.57.1.21-1 set to be updated
---> Package words.noarch 0:3.0-9.1 set to be updated
---> Package rhn-setup-gnome.noarch 0:0.4.19-17.el5 set to be updated
---> Package psa-appvault-openbiblio.noarch 0:0.5-8204720080409011541 set to be updated
---> Package device-mapper-multipath.i386 0:0.4.7-23.el5 set to be updated
---> Package systemtap.i386 0:0.7.2-2.el5 set to be updated
---> Package sabayon-apply.i386 0:2.12.4-6.el5 set to be updated
---> Package psa-locale-it-IT.noarch 0:8.6-build86080716.14 set to be updated
---> Package dbus-devel.i386 0:1.1.2-12.el5 set to be updated
---> Package psa-autoinstaller.i386 0:3.3.2-080710.09 set to be updated
---> Package dhcpv6-client.i386 0:1.0.10-16.el5 set to be updated
---> Package ghostscript.i386 0:8.15.2-9.4.el5 set to be updated
---> Package mysql-server.i386 0:5.0.58-1.el5.art set to be updated
---> Package util-linux.i386 0:2.13-0.50.el5 set to be updated
---> Package libutempter.i386 0:1.1.4-4.el5 set to be updated
---> Package acpid.i386 0:1.0.4-7.el5 set to be updated
---> Package hal.i386 0:0.5.8.1-38.el5 set to be updated
---> Package psa.i586 0:8.6.0-cos5.build86080722.00 set to be updated
filelists.xml.gz          100% |=========================| 9.6 MB    00:09     
filelists.xml.gz          100% |=========================| 120 kB    00:00     
filelists.xml.gz          100% |=========================|  18 kB    00:00     
filelists.xml.gz          100% |=========================| 952 kB    00:00     
filelists.xml.gz          100% |=========================| 177 kB    00:00     
--> Processing Dependency: sw-libxslt >= 1.1.20 for package: psa
--> Processing Dependency: /usr/lib/sw/libxmlrpc.so.3 for package: psa
--> Processing Dependency: libmysqlclient.so.15 for package: psa
--> Processing Dependency: sw-libxml2-python >= 2.6.27 for package: psa
--> Processing Dependency: /usr/lib/sw/libxslt.so.1 for package: psa
--> Processing Dependency: /usr/lib/sw/libxmlrpc_xmltok.so.3 for package: psa
--> Processing Dependency: /usr/lib/sw/libexslt.so.0 for package: psa
--> Processing Dependency: /usr/lib/sw/libxmlrpc_xmlparse.so.3 for package: psa
--> Processing Dependency: /usr/lib/sw/libxmlrpc_util.so.3 for package: psa
--> Processing Dependency: /usr/lib/sw/libxmlrpc_server.so.3 for package: psa
--> Processing Dependency: sw-libxml2 >= 2.6.27 for package: psa
--> Processing Dependency: /usr/lib/sw/libxmlrpc_cpp.so.3 for package: psa
--> Processing Dependency: /usr/lib/sw/libxml2.so.2 for package: psa
---> Package openssl.i686 0:0.9.8e-7.el5 set to be updated
---> Package kbd.i386 0:1.12-21.el5 set to be updated
---> Package psacct.i386 0:6.3.2-44.el5 set to be updated
---> Package psa-spamassassin.i586 0:8.6.0-cos5.build86080722.00 set to be updated
---> Package rdate.i386 0:1.4-8.el5 set to be updated
---> Package psa-appvault-advancedpoll.noarch 0:2.03-8203720080409005333 set to be updated
---> Package xorg-x11-drv-i810.i386 0:1.6.5-9.21.el5 set to be updated
---> Package psa-api-rpc.noarch 0:8.6.0-cos5.build86080930.08 set to be updated
---> Package rpm-devel.i386 0:4.4.2.3-9.el5 set to be updated
---> Package elfutils.i386 0:0.137-3.el5 set to be updated
---> Package perl.i386 4:5.8.8-18.el5 set to be updated
---> Package crash.i386 0:4.0-7.2.3.el5_3.1 set to be updated
---> Package dovecot.i386 0:1.0.7-7.el5 set to be updated
---> Package gnupg.i386 0:1.4.5-14 set to be updated
---> Package esc.i386 0:1.0.0-39.el5 set to be updated
---> Package openldap-devel.i386 0:2.3.43-3.el5 set to be updated
---> Package tcpdump.i386 14:3.9.4-14.el5 set to be updated
---> Package elfutils-libelf-devel-static.i386 0:0.137-3.el5 set to be updated
---> Package psa-appvault-siteframe.noarch 0:3.2.2-8202920080409012006 set to be updated
---> Package newt.i386 0:0.52.2-12.el5 set to be updated
---> Package NetworkManager.i386 1:0.7.0-3.el5 set to be updated
---> Package openssh.i386 0:4.3p2-29.el5 set to be updated
---> Package openldap.i386 0:2.3.43-3.el5 set to be updated
---> Package mesa-libGLU.i386 0:6.5.1-7.7.el5 set to be updated
---> Package psa-appvault-bbclone.noarch 0:0.4.9-8200320080409005500 set to be updated
---> Package sabayon.i386 0:2.12.4-6.el5 set to be updated
---> Package paps.i386 0:0.6.6-18.el5 set to be updated
---> Package glx-utils.i386 0:6.5.1-7.7.el5 set to be updated
---> Package policycoreutils.i386 0:1.33.12-14.2.el5 set to be updated
--> Processing Dependency: libselinux-utils for package: policycoreutils
---> Package vnc-server.i386 0:4.1.2-14.el5 set to be updated
---> Package gstreamer.i386 0:0.10.20-3.el5 set to be updated
---> Package system-config-printer.i386 0:0.7.32.10-1.el5 set to be updated
---> Package xorg-x11-drv-nv.i386 0:2.1.12-3.el5 set to be updated
---> Package SysVinit.i386 0:2.86-15.el5 set to be updated
---> Package setup.noarch 0:2.5.58-4.el5 set to be updated
---> Package psa-pylibplesk.i586 0:8.6.0-cos5.build86080722.00 set to be updated
---> Package psa-appvault-webshopmanager.noarch 0:2.0-8203120080409012829 set to be updated
---> Package libgcc.i386 0:4.1.2-44.el5 set to be updated
---> Package traceroute.i386 3:2.0.1-5.el5 set to be updated
---> Package patch.i386 0:2.5.4-29.2.3.el5 set to be updated
---> Package initscripts.i386 0:8.45.25-1.el5 set to be updated
---> Package php-cli.i386 0:5.2.8-3.el5.art set to be updated
---> Package psa-appvault-smf.noarch 0:1.1.2-8203320080409012015 set to be updated
---> Package logrotate.i386 0:3.7.4-9 set to be updated
---> Package libgomp.i386 0:4.3.2-7.el5 set to be updated
---> Package shadow-utils.i386 2:4.0.17-14.el5 set to be updated
---> Package system-config-lvm.noarch 0:1.1.5-1.0.el5 set to be updated
---> Package rhnlib.noarch 0:2.2.6-2.el5 set to be updated
---> Package pam_krb5.i386 0:2.2.14-10 set to be updated
---> Package ppp.i386 0:2.4.4-2.el5 set to be updated
---> Package psa-appvault-tikiwiki.noarch 0:1.9.7-8203920080409012557 set to be updated
---> Package file.i386 0:4.17-15 set to be updated
---> Package nss_ldap.i386 0:253-17.el5 set to be updated
--> Processing Dependency: libfipscheck.so.1 for package: nss_ldap
---> Package popt.i386 0:1.10.2.3-9.el5 set to be updated
---> Package libgcrypt.i386 0:1.2.4-1.el5 set to be updated
---> Package ethtool.i386 0:6-2.el5 set to be updated
---> Package xen-libs.i386 0:3.0.3-80.el5 set to be updated
---> Package pam.i386 0:0.99.6.2-4.el5 set to be updated
---> Package libgfortran.i386 0:4.1.2-44.el5 set to be updated
---> Package sos.noarch 0:1.7-9.16.el5 set to be updated
---> Package smartmontools.i386 1:5.38-2.el5 set to be updated
---> Package mysql.i386 0:5.0.58-1.el5.art set to be updated
---> Package metacity.i386 0:2.16.0-12.el5 set to be updated
---> Package authconfig.i386 0:5.3.21-5.el5 set to be updated
---> Package psa-appvault-gtchat.noarch 0:0.93-8003020080409010834 set to be updated
---> Package ntp.i386 0:4.2.2p1-9.el5_3.1 set to be updated
---> Package xorg-x11-server-Xvfb.i386 0:1.1.1-48.52.el5 set to be updated
---> Package findutils.i386 1:4.2.27-5.el5 set to be updated
---> Package psa-appvault-xoops.noarch 0:2.2-8204820080409012846 set to be updated
---> Package php-common.i386 0:5.2.8-3.el5.art set to be updated
---> Package NetworkManager-gnome.i386 1:0.7.0-3.el5 set to be updated
---> Package sudo.i386 0:1.6.9p17-3.el5 set to be updated
---> Package psa-horde.noarch 0:3.1.7-cos5.build86080722.00 set to be updated
--> Processing Dependency: psa-pear >= 1.4.9 for package: psa-horde
---> Package psa-appvault-postnuke.noarch 0:0.761a-8205620080409011859 set to be updated
---> Package openssh-server.i386 0:4.3p2-29.el5 set to be updated
---> Package openldap-clients.i386 0:2.3.43-3.el5 set to be updated
---> Package rpm-python.i386 0:4.4.2.3-9.el5 set to be updated
---> Package e2fsprogs-libs.i386 0:1.39-20.el5 set to be updated
---> Package psa-appvault-webcalendar.noarch 0:1.0.5-8201020080409012824 set to be updated
---> Package bash.i386 0:3.2-24.el5 set to be updated
---> Package pam-devel.i386 0:0.99.6.2-4.el5 set to be updated
---> Package gnome-power-manager.i386 0:2.16.0-10.el5 set to be updated
---> Package yum-rhn-plugin.noarch 0:0.5.3-30.el5 set to be updated
---> Package gnome-terminal.i386 0:2.16.0-5.3.el5 set to be updated
---> Package php-gd.i386 0:5.2.8-3.el5.art set to be updated
--> Processing Dependency: libt1.so.5 for package: php-gd
---> Package psa-appvault-geeklog.noarch 0:1.4.1-8200320080409010751 set to be updated
---> Package strace.i386 0:4.5.18-2.el5_3.2 set to be updated
---> Package neon.i386 0:0.25.5-10.el5 set to be updated
---> Package python-urlgrabber.noarch 0:3.1.0-5.el5 set to be updated
---> Package nmap.i386 2:4.68-1.el5.art set to be updated
---> Package yum-security.noarch 0:1.1.16-13.el5 set to be updated
---> Package elfutils-libs.i386 0:0.137-3.el5 set to be updated
---> Package module-init-tools.i386 0:3.3-0.pre3.1.42.el5 set to be updated
---> Package redhat-rpm-config.noarch 0:8.0.45-29.el5 set to be updated
---> Package rhn-check.noarch 0:0.4.19-17.el5 set to be updated
---> Package xorg-x11-server-Xnest.i386 0:1.1.1-48.52.el5 set to be updated
---> Package psa-locale-ru-RU.noarch 0:8.6-build86080716.14 set to be updated
---> Package psa-appvault-typo3.noarch 0:4.0-8202020080424050531 set to be updated
---> Package libgcj.i386 0:4.1.2-44.el5 set to be updated
---> Package subversion.i386 0:1.4.2-4.el5 set to be updated
---> Package rhpxl.i386 0:0.41.1-7.el5 set to be updated
---> Package httpd.i386 0:2.2.3-22.el5 set to be updated
---> Package psa-appvault-coppermine.noarch 0:1.4.16-8200220080409005533 set to be updated
---> Package linuxwacom.i386 0:0.7.8.3-5.el5 set to be updated
---> Package perl-DBD-Pg.i386 0:1.49-2.el5 set to be updated
---> Package quota.i386 1:3.13-1.2.5.el5 set to be updated
---> Package mkisofs.i386 9:2.01-10.7.el5 set to be updated
---> Package samba-common.i386 0:3.0.33-3.7.el5 set to be updated
---> Package bind-chroot.i386 30:9.3.4-10.P1.el5 set to be updated
---> Package libhugetlbfs.i386 0:1.3-3.el5 set to be updated
---> Package openssh-clients.i386 0:4.3p2-29.el5 set to be updated
---> Package libvirt.i386 0:0.3.3-14.el5 set to be updated
---> Package glibc-devel.i386 0:2.5-34 set to be updated
---> Package psa-appvault-phpmoney.noarch 0:1.3-8204320080409011649 set to be updated
---> Package ftp.i386 0:0.17-35.el5 set to be updated
---> Package procps.i386 0:3.2.7-11.1.el5 set to be updated
---> Package m2crypto.i386 0:0.16-6.el5.3 set to be updated
---> Package psa-appvault-merchant.noarch 0:5.3-8003020080416013305 set to be updated
---> Package perl-DBD-MySQL.i386 0:3.0007-2.el5 set to be updated
---> Package psa-appvault-brim.noarch 0:2.0.0-8203120080409005520 set to be updated
---> Package psa-imp.noarch 0:4.1.6-cos5.build86080722.00 set to be updated
---> Package alsa-utils.i386 0:1.0.17-1.el5 set to be updated
---> Package psa-appvault-egroupware.noarch 0:1.4.002-8201220080409005942 set to be updated
---> Package nfs-utils.i386 1:1.0.9-40.el5 set to be updated
---> Package dbus.i386 0:1.1.2-12.el5 set to be updated
--> Processing Dependency: dbus-libs = 1.1.2-12.el5 for package: dbus
---> Package glibc-common.i386 0:2.5-34 set to be updated
---> Package psa-appvault-phpsurveyor.noarch 0:0.98-8204320080409011723 set to be updated
---> Package gcc-gfortran.i386 0:4.1.2-44.el5 set to be updated
---> Package cryptsetup-luks.i386 0:1.0.3-4.el5 set to be updated
---> Package psa-courier-imap-add.i586 0:8.6.0-cos5.build86080930.08 set to be updated
---> Package redhat-release.i386 0:5Server-5.3.0.3 set to be updated
---> Package rhel-instnum.noarch 0:1.0.9-1.el5 set to be updated
---> Package psa-appvault-serendipity.noarch 0:1.1.2-8203020080409011950 set to be updated
---> Package psa-appvault-phpmyvisites.noarch 0:2.3-8202820080409011701 set to be updated
---> Package psa-appvault-phpbb.noarch 0:3.0.0-8200820080409011626 set to be updated
---> Package cups.i386 1:1.3.7-8.el5 set to be updated
--> Processing Dependency: libdns_sd.so.1 for package: cups
---> Package psa-appvault-mantis.noarch 0:1.1.1-8200320080426054935 set to be updated
---> Package krb5-devel.i386 0:1.6.1-31.el5 set to be updated
---> Package iputils.i386 0:20020927-45.el5 set to be updated
---> Package kernel-headers.i386 0:2.6.18-128.el5 set to be updated
---> Package prelink.i386 0:0.4.0-2.el5 set to be updated
---> Package python.i386 0:2.4.3-24.el5 set to be updated
---> Package zip.i386 0:2.31-2.el5 set to be updated
---> Package e2fsprogs-devel.i386 0:1.39-20.el5 set to be updated
---> Package xterm.i386 0:215-8.el5 set to be updated
---> Package autofs.i386 1:5.0.1-0.rc2.102 set to be updated
---> Package psa-appvault-owl.noarch 0:0.80-8203620080409011601 set to be updated
---> Package avahi-glib.i386 0:0.6.16-1.el5_2.1 set to be updated
---> Package psa-appvault-noahclass.noarch 0:1.3-8205520080409011532 set to be updated
---> Package libgcrypt-devel.i386 0:1.2.4-1.el5 set to be updated
---> Package psa-appvault-phpwebsite.noarch 0:0.10.2-8203420080409011738 set to be updated
---> Package xorg-x11-drv-ati.i386 0:6.6.3-3.22.el5 set to be updated
---> Package gcc-c++.i386 0:4.1.2-44.el5 set to be updated
---> Package system-config-network.noarch 0:1.3.99.12-1.el5 set to be updated
---> Package xorg-x11-server-Xorg.i386 0:1.1.1-48.52.el5 set to be updated
---> Package lvm2.i386 0:2.02.40-6.el5 set to be updated
---> Package alsa-lib.i386 0:1.0.17-1.el5 set to be updated
---> Package net-snmp-libs.i386 1:5.3.2.2-5.el5 set to be updated
---> Package psa-backup-manager.i586 0:8.6.0-cos5.build86080930.08 set to be updated
---> Package psa-locale-es-ES.noarch 0:8.6-build86080716.14 set to be updated
---> Package tmpwatch.i386 0:2.9.7-1.1.el5.2 set to be updated
---> Package gstreamer-plugins-base.i386 0:0.10.20-3.el5 set to be updated
---> Package ccid.i386 0:1.3.8-1.el5 set to be updated
---> Package psa-appvault-mambo.noarch 0:4.6.2-8201520080409011052 set to be updated
---> Package gdb.i386 0:6.8-27.el5 set to be updated
---> Package device-mapper-event.i386 0:1.02.28-2.el5 set to be updated
---> Package parted.i386 0:1.8.1-23.el5 set to be updated
---> Package glibc.i686 0:2.5-34 set to be updated
---> Package psa-api.noarch 0:8.6.0-cos5.build86080930.08 set to be updated
---> Package usermode.i386 0:1.88-3.el5.2 set to be updated
---> Package elfutils-libelf-devel.i386 0:0.137-3.el5 set to be updated
---> Package ORBit2.i386 0:2.14.3-5.el5 set to be updated
---> Package libselinux-python.i386 0:1.33.4-5.1.el5 set to be updated
---> Package psa-appvault-phpmyfamily.noarch 0:1.4.1-8203420080409011655 set to be updated
---> Package system-config-printer-libs.i386 0:0.7.32.10-1.el5 set to be updated
---> Package audit-libs-python.i386 0:1.7.7-6.el5 set to be updated
---> Package php-ldap.i386 0:5.2.8-3.el5.art set to be updated
---> Package psa-selinux.noarch 0:8.6.0-cos5.build86080722.00 set to be updated
---> Package gstreamer-tools.i386 0:0.10.20-3.el5 set to be updated
---> Package psa-appvault-xrms.noarch 0:1.19-8203120080415030843 set to be updated
---> Package psa-appvault-oscommerce.noarch 0:2.2ms2-8206120080409011549 set to be updated
---> Package psa-appvault-tutos.noarch 0:1.88-8203820080409012705 set to be updated
---> Package ecryptfs-utils.i386 0:56-8.el5 set to be updated
---> Package psa-appvault-phpwiki.noarch 0:1.3.11-8204320080409011808 set to be updated
---> Package psa-appvault-wordpress.noarch 0:2.3.3-8200520080412062207 set to be updated
---> Package krb5-libs.i386 0:1.6.1-31.el5 set to be updated
---> Package mcstrans.i386 0:0.2.11-3.el5 set to be updated
---> Package psa-locale-zh-CN.noarch 0:8.6-build86080716.14 set to be updated
---> Package psa-appvault-autoindex.noarch 0:2.2.4-8200220080409005350 set to be updated
---> Package numactl.i386 0:0.9.8-7.el5 set to be updated
---> Package kudzu.i386 0:1.2.57.1.21-1 set to be updated
---> Package filesystem.i386 0:2.4.0-2 set to be updated
---> Package libpcap.i386 14:0.9.4-14.el5 set to be updated
---> Package ksh.i386 0:20080202-2.el5 set to be updated
---> Package psa-appvault-drupal.noarch 0:6.1-8200320080409005854 set to be updated
---> Package system-config-network-tui.noarch 0:1.3.99.12-1.el5 set to be updated
---> Package mod_ssl.i386 1:2.2.3-22.el5 set to be updated
---> Package perl-Apache-ASP.i386 0:2.59-0.93298 set to be updated
---> Package rpm.i386 0:4.4.2.3-9.el5 set to be updated
---> Package psa-appvault-phpbugtracker.noarch 0:1.19-8203820080416050605 set to be updated
---> Package rpm-build.i386 0:4.4.2.3-9.el5 set to be updated
---> Package redhat-release-notes.i386 0:5Server-25 set to be updated
---> Package psa-proftpd.i586 0:1.3.1-cos5.build86080722.00 set to be updated
---> Package ipsec-tools.i386 0:0.6.5-13.el5 set to be updated
---> Package authconfig-gtk.i386 0:5.3.21-5.el5 set to be updated
---> Package psa-appvault-gallery.noarch 0:2.2-8201720080409010331 set to be updated
---> Package mlocate.i386 0:0.15-1.el5.1 set to be updated
---> Package psa-locale-fr-FR.noarch 0:8.6-build86080716.14 set to be updated
---> Package systemtap-runtime.i386 0:0.7.2-2.el5 set to be updated
---> Package redhat-menus.noarch 0:6.7.8-3.el5 set to be updated
---> Package binutils.i386 0:2.17.50.0.6-9.el5 set to be updated
---> Package psa-appvault-myorgbook.noarch 0:2.8-8202720080409011528 set to be updated
---> Package avahi.i386 0:0.6.16-1.el5_2.1 set to be updated
---> Package php-imap.i386 0:5.2.8-3.el5.art set to be updated
---> Package psa-appvault-phpdig.noarch 0:1.85-8203120080409011645 set to be updated
--> Processing Dependency: php <= 5.2.0 for package: php-sqlite2
---> Package libstdc++.i386 0:4.1.2-44.el5 set to be updated
---> Package psa-ftputil.i586 0:8.6.0-cos5.build86080722.00 set to be updated
---> Package tcsh.i386 0:6.14-14.el5 set to be updated
---> Package psa-appvault-tellme.noarch 0:1.2-8202720080409012523 set to be updated
---> Package desktop-printing.i386 0:0.19-20.2.el5 set to be updated
---> Package audit-libs.i386 0:1.7.7-6.el5 set to be updated
---> Package samba-client.i386 0:3.0.33-3.7.el5 set to be updated
---> Package psa-appvault-docfaq.noarch 0:1.71-8203720080409005800 set to be updated
---> Package elfutils-libelf.i386 0:0.137-3.el5 set to be updated
---> Package firstboot-tui.i386 0:1.4.27.7-1.el5 set to be updated
---> Package gstreamer-plugins-good.i386 0:0.10.9-1.el5 set to be updated
---> Package policycoreutils-gui.i386 0:1.33.12-14.2.el5 set to be updated
--> Processing Dependency: selinux-policy-devel for package: policycoreutils-gui
---> Package rpm-libs.i386 0:4.4.2.3-9.el5 set to be updated
---> Package libvirt-python.i386 0:0.3.3-14.el5 set to be updated
---> Package system-config-samba.noarch 0:1.2.41-3.el5 set to be updated
---> Package kpartx.i386 0:0.4.7-23.el5 set to be updated
---> Package firstboot.i386 0:1.4.27.7-1.el5 set to be updated
---> Package tcp_wrappers.i386 0:7.6-40.6.el5 set to be updated
---> Package nscd.i386 0:2.5-34 set to be updated
---> Package psa-libpam-plesk.i586 0:8.6.0-cos5.build86080722.00 set to be updated
---> Package psa-locale-de-DE.noarch 0:8.6-build86080805.15 set to be updated
---> Package dosfstools.i386 0:2.11-7.el5 set to be updated
---> Package cpp.i386 0:4.1.2-44.el5 set to be updated
---> Package psa-locale-ja-JP.noarch 0:8.6-build86080716.14 set to be updated
---> Package php-mysql.i386 0:5.2.8-3.el5.art set to be updated
---> Package diffstat.i386 0:1.41-1.2.3.el5 set to be updated
---> Package libvolume_id.i386 0:095-14.19.el5 set to be updated
---> Package psa-appvault-cslh.noarch 0:2.14.5-8200220080409005735 set to be updated
---> Package psa-appvault-phpbook.noarch 0:1.50-8203220080409011638 set to be updated
---> Package pm-utils.i386 0:0.99.3-10.el5 set to be updated
---> Package yum.noarch 0:3.2.19-18.el5 set to be updated
---> Package krb5-workstation.i386 0:1.6.1-31.el5 set to be updated
---> Package nash.i386 0:5.1.19.6-44 set to be updated
---> Package usermode-gtk.i386 0:1.88-3.el5.2 set to be updated
---> Package php.i386 0:5.2.8-3.el5.art set to be updated
---> Package ypbind.i386 3:1.19-11.el5 set to be updated
---> Package rhn-client-tools.noarch 0:0.4.19-17.el5 set to be updated
---> Package psa-appvault-phpads.noarch 0:2.0.8-8203520080409011611 set to be updated
---> Package newt-devel.i386 0:0.52.2-12.el5 set to be updated
---> Package audit.i386 0:1.7.7-6.el5 set to be updated
---> Package psa-appvault-pmachinefree.noarch 0:2.4-8203520080409011839 set to be updated
---> Package python-devel.i386 0:2.4.3-24.el5 set to be updated
---> Package xorg-x11-drv-mga.i386 0:1.4.2-10.el5 set to be updated
---> Package psa-appvault-uebimiau.noarch 0:2.7.8-8203720080409012807 set to be updated
---> Package mod_perl.i386 0:2.0.4-6.el5 set to be updated
---> Package dmraid.i386 0:1.0.0.rc13-33.el5 set to be updated
---> Package dhcdbd.i386 0:2.2-2.el5 set to be updated
---> Package libselinux.i386 0:1.33.4-5.1.el5 set to be updated
---> Package selinux-policy.noarch 0:2.4.6-203.el5 set to be updated
---> Package psa-appvault-anyinventory.noarch 0:2.0-8202820080409005337 set to be updated
---> Package php-pdo.i386 0:5.2.8-3.el5.art set to be updated
---> Package psa-appvault-moodle.noarch 0:1.8-8202920080409011254 set to be updated
---> Package rhn-setup.noarch 0:0.4.19-17.el5 set to be updated
---> Package unzip.i386 0:5.52-3.el5 set to be updated
---> Package bind.i386 30:9.3.4-10.P1.el5 set to be updated
---> Package OpenIPMI-libs.i386 0:2.0.6-11.el5 set to be updated
---> Package kexec-tools.i386 0:1.102pre-56.el5_3.1 set to be updated
---> Package e2fsprogs.i386 0:1.39-20.el5 set to be updated
---> Package system-config-kdump.noarch 0:1.0.14-4.el5 set to be updated
---> Package dbus-glib.i386 0:0.73-8.el5 set to be updated
---> Package man-pages.noarch 0:2.39-12.el5 set to be updated
---> Package psa-appvault-plog.noarch 0:1.0-8203620080409011828 set to be updated
---> Package openssh-askpass.i386 0:4.3p2-29.el5 set to be updated
---> Package selinux-policy-targeted.noarch 0:2.4.6-203.el5 set to be updated
---> Package psa-proftpd-xinetd.i586 0:1.3.1-cos5.build86080722.00 set to be updated
---> Package device-mapper.i386 0:1.02.28-2.el5 set to be updated
---> Package httpd-manual.i386 0:2.2.3-22.el5 set to be updated
---> Package openssl-devel.i386 0:0.9.8e-7.el5 set to be updated
---> Package cpuspeed.i386 1:1.2.1-5.el5 set to be updated
---> Package vixie-cron.i386 4:4.1-76.el5 set to be updated
---> Package psa-locale-base-en-US.noarch 0:8.6.0-cos5.build86080722.00 set to be updated
---> Package pkinit-nss.i386 0:0.7.6-1.el5 set to be updated
---> Package glibc-headers.i386 0:2.5-34 set to be updated
---> Package libselinux-devel.i386 0:1.33.4-5.1.el5 set to be updated
---> Package psa-appvault-joomla.noarch 0:1.0.15-8200720080409010851 set to be updated
---> Package samba.i386 0:3.0.33-3.7.el5 set to be updated
--> Processing Dependency: perl(Convert::ASN1) for package: samba
---> Package bind-libs.i386 30:9.3.4-10.P1.el5 set to be updated
---> Package libstdc++-devel.i386 0:4.1.2-44.el5 set to be updated
---> Package bind-utils.i386 30:9.3.4-10.P1.el5 set to be updated
---> Package udev.i386 0:095-14.19.el5 set to be updated
---> Package OpenIPMI-tools.i386 0:2.0.6-11.el5 set to be updated
---> Package psa-php5-configurator.noarch 0:1.4.0-cos5.build86080722.00 set to be updated
---> Package kernel.i686 0:2.6.18-128.el5 set to be installed
---> Package cups-libs.i386 1:1.3.7-8.el5 set to be updated
---> Package spamassassin.i386 1:3.2.5-1.el5.art set to be updated
---> Package psa-appvault-phprojekt.noarch 0:5.2-8200820080409011713 set to be updated
---> Package iproute.i386 0:2.6.18-9.el5 set to be updated
---> Package vnc.i386 0:4.1.2-14.el5 set to be updated
---> Package wpa_supplicant.i386 1:0.5.10-8.el5 set to be updated
---> Package perl-DBI.i386 0:1.52-2.el5 set to be updated
---> Package kernel-devel.i686 0:2.6.18-128.el5 set to be installed
---> Package psa-migration-manager.i586 0:8.6.0-cos5.build86080930.08 set to be updated
---> Package coreutils.i386 0:5.97-19.el5 set to be updated
---> Package mkinitrd.i386 0:5.1.19.6-44 set to be updated
---> Package NetworkManager-glib.i386 1:0.7.0-3.el5 set to be updated
---> Package squid.i386 7:2.6.STABLE21-3.el5 set to be updated
--> Running transaction check
---> Package perl-Convert-ASN1.noarch 0:0.20-1.1 set to be updated
--> Processing Dependency: psa-security = 8.2 for package: psa-fileserver
--> Processing Dependency: psa-security = 8.2 for package: cs-gs
--> Processing Dependency: psa-security = 8.2 for package: psa-firewall
--> Processing Dependency: psa-security = 8.2 for package: psa-vpn
---> Package fipscheck.i386 0:1.0.3-1.el5 set to be updated
---> Package sw-libxml2.i386 0:2.6.27-5.centos5 set to be updated
---> Package plesk-skins.noarch 0:8.6.0-0.97326 set to be updated
---> Package sw-libxslt.i386 0:1.1.20-5.centos5 set to be updated
---> Package psa-pear.noarch 0:1.4.9-20060517.1 set to be updated
---> Package psa-hotfix5-8.6.0.i586 0:8.6.0-cos5.build86080930.08 set to be updated
--> Processing Dependency: psa-hotfix4-8.6.0 = 8.6.0 for package: psa-hotfix5-8.6.0
---> Package sw-xmlrpc-c.i386 0:1.06.10-7.centos5 set to be updated
---> Package libselinux-utils.i386 0:1.33.4-5.1.el5 set to be updated
---> Package mysql-libs.i386 0:5.0.58-1.el5.art set to be updated
---> Package dbus-libs.i386 0:1.1.2-12.el5 set to be updated
--> Processing Dependency: php <= 5.2.0 for package: php-sqlite2
---> Package t1lib.i386 0:5.1.2-2.el5.art set to be updated
---> Package selinux-policy-devel.noarch 0:2.4.6-203.el5 set to be updated
---> Package sw-libxml2-python.i386 0:2.6.27-5.centos5 set to be updated
---> Package avahi-compat-libdns_sd.i386 0:0.6.16-1.el5_2.1 set to be updated
--> Running transaction check
--> Processing Dependency: psa-security = 8.2 for package: psa-fileserver
--> Processing Dependency: psa-security = 8.2 for package: cs-gs
--> Processing Dependency: psa-security = 8.2 for package: psa-firewall
--> Processing Dependency: psa-security = 8.2 for package: psa-vpn
---> Package psa-hotfix4-8.6.0.i586 0:8.6.0-cos5.build86080910.19 set to be updated
--> Processing Dependency: psa-hotfix3 = 8.6.0 for package: psa-hotfix4-8.6.0
--> Processing Dependency: php <= 5.2.0 for package: php-sqlite2
--> Running transaction check
--> Processing Dependency: psa-security = 8.2 for package: psa-fileserver
--> Processing Dependency: psa-security = 8.2 for package: cs-gs
--> Processing Dependency: psa-security = 8.2 for package: psa-firewall
--> Processing Dependency: psa-security = 8.2 for package: psa-vpn
---> Package psa-hotfix3.i586 0:8.6.0-cos5.build86080822.20 set to be updated
--> Processing Dependency: php <= 5.2.0 for package: php-sqlite2
--> Finished Dependency Resolution
Error: Missing Dependency: psa-security = 8.2 is needed by package psa-firewall
Error: Missing Dependency: psa-security = 8.2 is needed by package psa-fileserver
Error: Missing Dependency: php <= 5.2.0 is needed by package php-sqlite2
Error: Missing Dependency: psa-security = 8.2 is needed by package cs-gs
Error: Missing Dependency: psa-security = 8.2 is needed by package psa-vpn
[root@joshua freshapps.com]# service httpd restart
bash: service: command not found
[root@joshua freshapps.com]# /etc/init.d/httpd restart
Stopping httpd:                                            [  OK  ]
Starting httpd: [Fri Jan 30 08:06:50 2009] [warn] Useless use of AllowOverride in line 1003.
                                                           [  OK  ]
[root@joshua freshapps.com]#


Is it ok if i paste all of that? Either way, it seems as though some dependencies were not there. Any ideas would be great!!!!!!!

THanks!!!
J.J.


Top
 Profile  
 
 Post subject:
Unread postPosted: Fri Jan 30, 2009 8:36 am 
Offline
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin

Joined: Wed Dec 31, 1969 8:00 pm
Posts: 7901
Location: earth
you'll have to remove sitebuilder to use php 5.2


Top
 Profile  
 
 Post subject:
Unread postPosted: Fri Jan 30, 2009 1:41 pm 
Offline
Long Time Forum Regular
Long Time Forum Regular

Joined: Thu Dec 09, 2004 11:19 am
Posts: 2049
jj - you have an awful lot of stuff that's not been updated. I mean just normal stuff, not related to updating php.

I think it would be sensible to do things slowly.

Then think about things carefully. The package list you pasted includes, for example, bind-chroot. This is not a good thing - it can/will cause problems with plesk. There's also hotfixes and god knows what for plesk too. Installing them may cause you problems, especially if done at the same time as everything else.

You could be lucky and it will all go OK, but I would be very very very cautious. At the very least make a backup of everything in /etc/ and ideally backup the whole server.

In fact I'm inclined to say it WILL go horribly wrong if you try to update all that stuff at once (once you get past the dependancy thing).

If you have clients on your machine and it goes down or plesk gets borked they obviously won't be happy.

In this sort of situation, if you are not 100% comfortable with the shell, and potentially poking plesk around a bit to get it running, possibly fixing bind configs, possibly ending up with a borked plesk and having to deal with that and so on, possibly ending up with a borked php and and and .....it might be best to employ a third party to 1) update your system and 2) update plesk [BUT NOT TO VERSION 9!!! Bad idea. Do Not Go There] and 3) update to php 5.2.x for you.


Also, is there a particular reason why you want to update PHP?

_________________
--------------------------------
<advert>
If you want to rent a UK-based VPS that comes with friendly advice and support from a fellow ART fan, please get in touch.
</advert>


Top
 Profile  
 
 Post subject:
Unread postPosted: Sat Jan 31, 2009 1:12 pm 
Offline
Forum Regular
Forum Regular

Joined: Mon Oct 29, 2007 6:51 pm
Posts: 644
I agree with faris, take things slowly when upgrading, you never know how things will react, and if you upgrade too much stuff at once you wont know what got you in trouble.

Start small and do
yum update php

and do php first. Then you can worry about updating the system RPMs later.


Top
 Profile  
 
 Post subject:
Unread postPosted: Sat Jan 31, 2009 2:28 pm 
Offline
New Forum User
New Forum User

Joined: Thu Jan 29, 2009 2:13 pm
Posts: 3
Well,

I took you guys suggestion, took it slowly, and it went pretty smooth!
I had one lil problem, with copying my php.ini file. But I just copied the old one, and then everything seemed to work out great!

Thanks so much for the help!

ART is GREAT!

J.J.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

» Feed - Atomicorp

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group