store | blogs | forums | twitter | facebook | wiki | downloads | support portal
Atomic Secure Linux
It is currently Sat Oct 25, 2014 9:48 pm

» Feed - Atomicorp

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 16 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: SpamAssassin 3.2.4
Unread postPosted: Fri Jan 11, 2008 8:49 am 
Offline
Long Time Forum Regular
Long Time Forum Regular

Joined: Sat Aug 20, 2005 9:30 am
Posts: 2812
Location: The Netherlands
It seems Dag already has a spec file and packages up: http://dag.wieers.com/rpm/packages/spamassassin/

_________________
Lemonbit Internet Dedicated Server Management


Top
 Profile  
 
 Post subject:
Unread postPosted: Fri Jan 11, 2008 9:13 am 
Offline
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin

Joined: Wed Dec 31, 1969 8:00 pm
Posts: 7943
Location: earth
Thats because Dag and party rock. Thanks for the heads up!


Top
 Profile  
 
 Post subject: Re: SpamAssassin 3.2.4
Unread postPosted: Sat Jan 19, 2008 11:55 am 
Offline
Forum User
Forum User

Joined: Sun May 20, 2007 10:44 pm
Posts: 37
breun wrote:
It seems Dag already has a spec file and packages up: http://dag.wieers.com/rpm/packages/spamassassin/


Yes, I have installed 3.2.4 (Dag) but yum always appear 3.2.3... ART?? Do you have any idea?


Top
 Profile  
 
 Post subject:
Unread postPosted: Sat Jan 19, 2008 12:03 pm 
Offline
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin

Joined: Wed Dec 31, 1969 8:00 pm
Posts: 7943
Location: earth
I havent made an update yet, if you're looking at [atomic]


Top
 Profile  
 
 Post subject: DAG rpm
Unread postPosted: Wed Feb 06, 2008 6:41 am 
Offline
Forum User
Forum User

Joined: Sat Jan 20, 2007 6:57 pm
Posts: 83
Since I have been using the ART rpm for SpamAssassin it seems to conflict with the DAG rpm for SA. Does this mean I cannot use the DAG SpamAssassin rpm? Can I force it to upgrade or would that be dangerous?


Top
 Profile  
 
 Post subject:
Unread postPosted: Wed Feb 06, 2008 10:14 am 
Offline
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin

Joined: Wed Dec 31, 1969 8:00 pm
Posts: 7943
Location: earth
what kind of conflict are you having? You should be able to use rpmforge with atomic


Top
 Profile  
 
 Post subject:
Unread postPosted: Thu Feb 07, 2008 11:42 am 
Offline
Long Time Forum Regular
Long Time Forum Regular

Joined: Sat Aug 20, 2005 9:30 am
Posts: 2812
Location: The Netherlands
We have SpamAssassin 3.2.3 on our Plesk boxes. 'yum search spamassasin' shows rpmforge has 3.2.4 available, but 'yum update' doesn't say it's available for an upgrade. Strange. jpkelly, have you tried downloading the RPM from RPMforge and upgrading it manually? If so, what error did you get?

_________________
Lemonbit Internet Dedicated Server Management


Top
 Profile  
 
 Post subject:
Unread postPosted: Thu Feb 07, 2008 11:46 am 
Offline
Long Time Forum Regular
Long Time Forum Regular

Joined: Sat Aug 20, 2005 9:30 am
Posts: 2812
Location: The Netherlands
I just went ahead and tried it myself and to my surprise the 3.2.4 RPM from RPMforge installed just fine. I have no idea why yum did not see this update. Now, do I need to go and manually update all of our machines?

_________________
Lemonbit Internet Dedicated Server Management


Top
 Profile  
 
 Post subject:
Unread postPosted: Thu Feb 07, 2008 11:50 am 
Offline
Long Time Forum Regular
Long Time Forum Regular

Joined: Sat Aug 20, 2005 9:30 am
Posts: 2812
Location: The Netherlands
After I installed SpamAssassin 3.2.4 from RPMforge and ran 'yum update' again, yum suggests to update to SpamAssassin 3.2.3 from ART. I believe this is an epoch issue.

_________________
Lemonbit Internet Dedicated Server Management


Top
 Profile  
 
 Post subject:
Unread postPosted: Thu Feb 07, 2008 6:54 pm 
Offline
Forum User
Forum User

Joined: Sat Jan 20, 2007 6:57 pm
Posts: 83
scott wrote:
what kind of conflict are you having? You should be able to use rpmforge with atomic


after running:
rpm -i spamassassin-3.2.4-1.el4.rf.i386.rpm

I get a bunch of conflicting file messages like this:

file /etc/cron.d/sa-update from install of spamassassin-3.2.4-1.el4.rf conflicts with file from package spamassassin-3.2.3-3.el4.art
file /etc/mail/spamassassin/local.cf from install of spamassassin-3.2.4-1.el4.rf conflicts with file from package spamassassin-3.2.3-3.el4.art
file /etc/mail/spamassassin/spamassassin-default.rc from install of spamassassin-3.2.4-1.el4.rf conflicts with file from package spamassassin-3.2.3-3.el4.art
file /usr/bin/sa-compile from install of spamassassin-3.2.4-1.el4.rf conflicts with file from package spamassassin-3.2.3-3.el4.art
file /usr/bin/sa-update from install of spamassassin-3.2.4-1.el4.rf conflicts with file from package spamassassin-3.2.3-3.el4.art
file /usr/bin/spamassassin from install of spamassassin-3.2.4-1.el4.rf conflicts with file from package spamassassin-3.2.3-3.el4.art


Top
 Profile  
 
 Post subject:
Unread postPosted: Thu Feb 07, 2008 7:12 pm 
Offline
Long Time Forum Regular
Long Time Forum Regular

Joined: Sat Aug 20, 2005 9:30 am
Posts: 2812
Location: The Netherlands
Don't use the -i flag, cause you'd end up with two copies of SpamAssassin! Use the -U flag (U is for Upgrade). (Most people add -v and -h as well, so you can see what's going on.)

_________________
Lemonbit Internet Dedicated Server Management


Top
 Profile  
 
 Post subject:
Unread postPosted: Thu Feb 07, 2008 7:41 pm 
Offline
Forum User
Forum User

Joined: Sat Jan 20, 2007 6:57 pm
Posts: 83
breun wrote:
Don't use the -i flag, cause you'd end up with two copies of SpamAssassin! Use the -U flag (U is for Upgrade). (Most people add -v and -h as well, so you can see what's going on.)


doh!
ok i am pretty new at this rpm/yum stuff

yes it upgraded to 3.2.4 thanks!

funny thing as mentioned above: yum upgrade spamassassin now suggests "upgrading" to 3.2.3.

thanks again for the help!


Top
 Profile  
 
 Post subject:
Unread postPosted: Thu Feb 07, 2008 7:43 pm 
Offline
Long Time Forum Regular
Long Time Forum Regular

Joined: Sat Aug 20, 2005 9:30 am
Posts: 2812
Location: The Netherlands
It appears the 3.2.3 package uses an epoch number of 1, whereas the 3.2.4 package doesn't. Using an epoch number is a way to override the normal version number.

Also, don't forget to run service spamassassin restart after the upgrade or you'll still be running the 3.2.3 version of spamd.

_________________
Lemonbit Internet Dedicated Server Management


Top
 Profile  
 
 Post subject:
Unread postPosted: Sun Feb 17, 2008 5:14 am 
Offline
New Forum User
New Forum User

Joined: Fri Feb 15, 2008 6:28 am
Posts: 2
My Server using Fedora Core 5, which one should i download ?

is this spamassassin-3.2.4-1.el5.rf.i386.rpm compatible with FC5 ?

Thanks

Schatje


Top
 Profile  
 
 Post subject:
Unread postPosted: Sun Feb 17, 2008 6:27 am 
Offline
Long Time Forum Regular
Long Time Forum Regular

Joined: Sat Aug 20, 2005 9:30 am
Posts: 2812
Location: The Netherlands
RPMforge doesn't support FC5 anymore. You could try and download the source rpm yourself and try to rebuild it. But remember that FC5 is also no longer supported by the Fedora Project, so your server isn't getting any security fixes anymore. I'd look into migrating to an OS that is supported by its vendor. I highly recommend CentOS 5.

_________________
Lemonbit Internet Dedicated Server Management


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 16 posts ]  Go to page 1, 2  Next

» Feed - Atomicorp

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: Bing [Bot] and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group