store | blogs | forums | twitter | facebook | wiki | mailing lists | downloads | support portal
Atomic Secure Linux
It is currently Sat Apr 19, 2014 6:05 pm

» Feed - Atomicorp

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 22 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: ASL pre sales questions
Unread postPosted: Wed Aug 10, 2011 8:52 pm 
Offline
Forum User
Forum User

Joined: Wed Aug 10, 2011 5:52 pm
Posts: 12
Location: US
Hello everyone,

Hope this is the right place to ask some questions before buying/installing ASL, and was hoping to get your help and feedback.

We have a Dedicated Sever with the following:
CENTOS 5.6 x86_64
CPanel
Nginx
CSF
ModSecurity w/OWSAP mod security rules
ConfigServer ModSecurity Control

My question is by installing ASL is there any problem with this setup? Or anything's going to brake? Do we need to uninstall anything beforehand?

Thank you in advace.

DoubleA


Top
 Profile  
 
 Post subject: Re: ASL pre sales questions
Unread postPosted: Thu Aug 11, 2011 10:38 am 
Offline
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
User avatar

Joined: Thu Feb 07, 2008 7:49 pm
Posts: 3548
Location: Chantilly, VA
Quote:
We have a Dedicated Sever with the following:
CENTOS 5.6 x86_64
CPanel
Nginx
CSF
ModSecurity w/OWSAP mod security rules
ConfigServer ModSecurity Control


That should all work fine, I assume you are running Apache in front of nginx now to use the OWASP rules?

_________________
Michael Shinn
Atomicorp - Security For Everyone

Co-Author of Troubleshooting Linux Firewalls.


Top
 Profile  
 
 Post subject: Re: ASL pre sales questions
Unread postPosted: Thu Aug 11, 2011 5:26 pm 
Offline
Forum User
Forum User

Joined: Wed Aug 10, 2011 5:52 pm
Posts: 12
Location: US
mikeshinn wrote:
Quote:
We have a Dedicated Sever with the following:
CENTOS 5.6 x86_64
CPanel
Nginx
CSF
ModSecurity w/OWSAP mod security rules
ConfigServer ModSecurity Control


That should all work fine, I assume you are running Apache in front of nginx now to use the OWASP rules?


Thanks Mike for your reply.
We run nginx as a proxy on port 80 in front of Apache on port 8888.
Do we need to remove any mod security rules? Is there any conflict?

Also I still need your help.
We went ahead and purchased ASL last night.
But we forgot that we are using cpanel and missed to use the ASL cpanel installer.
We installed ASL using this command: wget -q -O - https://www.atomicorp.com/installers/asl |sh

We restarted the server and took over an hour to come back up online, however the ASL never worked.

Can you plese give us a direction on how to go about fixing this issue?

Thanks again and regards,


Top
 Profile  
 
 Post subject: Re: ASL pre sales questions
Unread postPosted: Thu Aug 11, 2011 9:13 pm 
Offline
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
User avatar

Joined: Thu Feb 07, 2008 7:49 pm
Posts: 3548
Location: Chantilly, VA
Quote:
We restarted the server and took over an hour to come back up online, however the ASL never worked.


Can you elaborate on what you mean by "ASL never worked"? Do you mean you didnt complete the install, or something else?

_________________
Michael Shinn
Atomicorp - Security For Everyone

Co-Author of Troubleshooting Linux Firewalls.


Top
 Profile  
 
 Post subject: Re: ASL pre sales questions
Unread postPosted: Fri Aug 12, 2011 1:53 pm 
Offline
Forum User
Forum User

Joined: Wed Aug 10, 2011 5:52 pm
Posts: 12
Location: US
I've been getting different errors everytime, and can not load aslweb:

Loading mirror speeds from cached hostfile
* atomic: www2.atomicorp.com
https://atomicorp.com/channels/asl-3.0/ ... repomd.xml: [Errno 14] HTTP Error 401: Authorization Required
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: asl-3.0. Please verify its path and try again
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* atomic: www2.atomicorp.com
https://atomicorp.com/channels/asl-3.0/ ... repomd.xml: [Errno 14] HTTP Error 401: Authorization Required
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: asl-3.0. Please verify its path and try again
,

Then we tried to re-install AS few times,, still getting different errors eventhough we followed all the instructions:

https://atomicorp.com/channels/asl-3.0/ ... repomd.xml: [Errno 14] HTTP Error 401: Authorization Required

We'll keep on trying, hope can see an end to this.

thanks


Top
 Profile  
 
 Post subject: Re: ASL pre sales questions
Unread postPosted: Fri Aug 12, 2011 2:01 pm 
Offline
Forum Regular
Forum Regular

Joined: Mon Apr 10, 2006 12:55 pm
Posts: 669
Did you try these instructions?

http://www.atomicorp.com/wiki/index.php ... stallation

_________________
"Its not a mac. I run linux... I'm actually cool." - scott


Top
 Profile  
 
 Post subject: Re: ASL pre sales questions
Unread postPosted: Fri Aug 12, 2011 2:51 pm 
Offline
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
User avatar

Joined: Thu Feb 07, 2008 7:49 pm
Posts: 3548
Location: Chantilly, VA
So, this message:

Quote:
https://atomicorp.com/channels/asl-3.0/ ... repomd.xml: [Errno 14] HTTP Error 401: Authorization Required


Means your ASL credentials are wrong or you have exceeded your license (installed ASL on more systems that you licensed):

https://www.atomicorp.com/wiki/index.ph ... her_mirror.

Quote from that FAQ:

"Explanation:

This means that your yum credentials, for accessing the ASL repository, are (1) incorrect, (2) your account has expired, or (3) you have exceeded your license (ASL is installed on more systems than your license allows) or. Reasons 1 and 2 are the most common, please check to make sure you credentials are correct and that your licenses are valid first.

Solution:

Step 1)

Check the License Manager to ensure your license(s) is/are up to date. You can access the license manager here:

https://www.atomicorp.com/support/license-manager.html

Step 2)

If your licenses are up to date, check to make sure you have ASL configured to use your current ASL username and password.

Sub Step 1) Log into the ASL GUI

Sub Step 2) Click on Configuration

Sub Step 3) Check to make sure the USERNAME and PASSWORD variables are set to your ASL credentials.

Sub Step 4) Then click the "Update" button to update your configuration.

Sub Step 5) Run the update process.

Alternatively, you can manually edit the file /etc/asl/config, and change the USERNAME and PASSWORD calues. Then run the command "asl -s -f" as root to set your configuration, and "asl -u" to update.


Quote:
Thanks Mike for your reply.
We run nginx as a proxy on port 80 in front of Apache on port 8888.
Do we need to remove any mod security rules? Is there any conflict?


You wont need the OWASP rules anymore. They won't conflict, but you wont need them either.

_________________
Michael Shinn
Atomicorp - Security For Everyone

Co-Author of Troubleshooting Linux Firewalls.


Top
 Profile  
 
 Post subject: Re: ASL pre sales questions
Unread postPosted: Fri Aug 12, 2011 5:29 pm 
Offline
Forum User
Forum User

Joined: Wed Aug 10, 2011 5:52 pm
Posts: 12
Location: US
Highland wrote:


Thanks Highland for your reply. Yes, these are instructions that we're following.


Top
 Profile  
 
 Post subject: Re: ASL pre sales questions
Unread postPosted: Fri Aug 12, 2011 5:35 pm 
Offline
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
User avatar

Joined: Thu Feb 07, 2008 7:49 pm
Posts: 3548
Location: Chantilly, VA
Quote:
Thanks Highland for your reply. Yes, these are instructions that we're following.


Did you try resetting your ASL credentials, per the faq?

If you are the same person that opened a case on this issue, your password is definitely wrong. I checked it myself, you need to make sure you are using the same password you use to log in here:

https://www.atomicorp.com/support/license-manager.html

And please see this FAQ again:

https://www.atomicorp.com/wiki/index.ph ... her_mirror.

This error:

Quote:
https://atomicorp.com/channels/asl-3.0/ ... repomd.xml: [Errno 14] HTTP Error 401: Authorization Required


Can only happen if your credentials are wrong (or if you have exceeded your license). Since I dont know what your ASL username is I can't check your licenses. Whats your ASL username?

A 401 error is the server itself saying your password (or username) is incorrect. Its not an error, or a bug generated by the installer. Thats your systems package manager (yum) trying to log into our servers to download the software, and our servers are correctly reporting that the credentials you used are wrong.

_________________
Michael Shinn
Atomicorp - Security For Everyone

Co-Author of Troubleshooting Linux Firewalls.


Top
 Profile  
 
 Post subject: Re: ASL pre sales questions
Unread postPosted: Fri Aug 12, 2011 5:58 pm 
Offline
Forum User
Forum User

Joined: Wed Aug 10, 2011 5:52 pm
Posts: 12
Location: US
mikeshinn wrote:
So, this message:

Quote:
https://atomicorp.com/channels/asl-3.0/ ... repomd.xml: [Errno 14] HTTP Error 401: Authorization Required


Means your ASL credentials are wrong or you have exceeded your license (installed ASL on more systems that you licensed):

https://www.atomicorp.com/wiki/index.ph ... her_mirror.

Quote from that FAQ:

"Explanation:

This means that your yum credentials, for accessing the ASL repository, are (1) incorrect, (2) your account has expired, or (3) you have exceeded your license (ASL is installed on more systems than your license allows) or. Reasons 1 and 2 are the most common, please check to make sure you credentials are correct and that your licenses are valid first.

Solution:

Step 1)

Check the License Manager to ensure your license(s) is/are up to date. You can access the license manager here:

https://www.atomicorp.com/support/license-manager.html

Step 2)

If your licenses are up to date, check to make sure you have ASL configured to use your current ASL username and password.

Sub Step 1) Log into the ASL GUI

Sub Step 2) Click on Configuration

Sub Step 3) Check to make sure the USERNAME and PASSWORD variables are set to your ASL credentials.

Sub Step 4) Then click the "Update" button to update your configuration.

Sub Step 5) Run the update process.

Alternatively, you can manually edit the file /etc/asl/config, and change the USERNAME and PASSWORD calues. Then run the command "asl -s -f" as root to set your configuration, and "asl -u" to update.


Quote:
Thanks Mike for your reply.
We run nginx as a proxy on port 80 in front of Apache on port 8888.
Do we need to remove any mod security rules? Is there any conflict?


You wont need the OWASP rules anymore. They won't conflict, but you wont need them either.



Thanks mike for your reply and info,

1- My ASL credentials are correct, up to date, and we use ASL only on One server.
We tried to install ASL few times today but still getting the same error.
We changed credentials couple times just in case, but still the same error.

2- Checked on the License Manager , and all is good cuz we just signed recently.

3- I can't get to ASL GUI, as the ASL's been installed yet.

4- file /etc/asl/config = file not found

5- Tried few different ways of installing and re installing ASL

same error:
https://atomicorp.com/channels/asl-3.0/ ... repomd.xml: [Errno 14] HTTP Error 401: Authorization Required
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: asl-3.0. Please verify its path and try again

Thank you


Top
 Profile  
 
 Post subject: Re: ASL pre sales questions
Unread postPosted: Fri Aug 12, 2011 6:00 pm 
Offline
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
User avatar

Joined: Thu Feb 07, 2008 7:49 pm
Posts: 3548
Location: Chantilly, VA
Quote:
1- My ASL credentials are correct, up to date, and we use ASL only on One server.
We tried to install ASL few times today but still getting the same error.
We changed credentials couple times just in case, but still the same error.


If you can tell me what your ASL username is, I'll check your credentials now. If you already opened a case about this (I see someone did earlier today, and their credentials were definitely wrong) what is the case number?

Quote:
2- Checked on the License Manager , and all is good cuz we just signed recently.


OK, so if the licenses are fine, then its definitely a credential issue. What username did you sign in with, and what username are you using to install ASL - and are you using the same in both cases?

Quote:
3- I can't get to ASL GUI, as the ASL's been installed yet.

4- file /etc/asl/config = file not found


Right, as you may have surmissed, thats because ASL is not installed yet. :-)

Quote:
5- Tried few different ways of installing and re installing ASL


Thats not going to make any different, the 401 error only means one thing: Your credentials are wrong. So reinstalling won't get you anywhere.

So lets work that our first.

Step 1

Check the License Manager to ensure your license(s) is/are up to date. You can access the license manager here:

https://www.atomicorp.com/support/license-manager.html

Step 2

Run the ASL installer. When asked to enter your "Enter subscription Username" and "Enter Subscription Password", enter the same credentials you used in step 1 to log into the license manager.

If you do not know what those credentials are, or you need to reset them, please visit this URL to reset your subscription credentials:

https://www.atomicorp.com/support/license-manager.html

If you still can't get this to work, please let me know what your username is and I'll personally look into this, and do a test install on a fresh centos image with your credentials.

_________________
Michael Shinn
Atomicorp - Security For Everyone

Co-Author of Troubleshooting Linux Firewalls.


Top
 Profile  
 
 Post subject: Re: ASL pre sales questions
Unread postPosted: Fri Aug 12, 2011 6:39 pm 
Offline
Forum User
Forum User

Joined: Wed Aug 10, 2011 5:52 pm
Posts: 12
Location: US
Hello Mike,

Thanks much for taking the time answering my questions.

1- My partner opned this case. Case number. 9769 . Please see all info there.

2- we used the same username to sign in and installing ASL

Thanks agian and regards,


Top
 Profile  
 
 Post subject: Re: ASL pre sales questions
Unread postPosted: Fri Aug 12, 2011 6:45 pm 
Offline
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
User avatar

Joined: Thu Feb 07, 2008 7:49 pm
Posts: 3548
Location: Chantilly, VA
Quote:
1- My partner opned this case. Case number. 9769 . Please see all info there.

2- we used the same username to sign in and installing ASL


Thanks, I just checked the case and you definitely are using the wrong password. Your partner posted the username and password you are using, and the password is definitely not correct - I just checked it myself, its wrong.

I also see your partner (or whomever) changed the password in the license manager, after we replied to your case that the was password wrong, to the password you were trying to use to install ASL. So, provided that you use those credentials you should be fine.

If you need to, you can also change the password yourself at this URL:

https://www.atomicorp.com/support/license-manager.html

_________________
Michael Shinn
Atomicorp - Security For Everyone

Co-Author of Troubleshooting Linux Firewalls.


Top
 Profile  
 
 Post subject: Re: ASL pre sales questions
Unread postPosted: Fri Aug 12, 2011 7:04 pm 
Offline
Forum User
Forum User

Joined: Wed Aug 10, 2011 5:52 pm
Posts: 12
Location: US
Thanks Mike,

What happned is that he was trying to so many different ways installing ASL, and it was a time when changed the password but then and forgot to listed correctly in the case,, so it was totaly a typo erro.

I corrected the password myself in the license-manager, and ran the ASL installer :
wget -q -O - http://www.atomicorp.com/installers/cpanel/installer |sh

and again, got the same error:
https://atomicorp.com/channels/asl-3.0/ ... repomd.xml: [Errno 14] HTTP Error 401: Authorization Required
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: asl-3.0. Please verify its path and try again


We're using one One server.
We checked our credentials.
We are using an up to date license.

hmm,, I wonder what could be the problem.

Thank you,


Top
 Profile  
 
 Post subject: Re: ASL pre sales questions
Unread postPosted: Fri Aug 12, 2011 7:23 pm 
Offline
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
User avatar

Joined: Thu Feb 07, 2008 7:49 pm
Posts: 3548
Location: Chantilly, VA
Quote:
and again, got the same error:
https://atomicorp.com/channels/asl-3.0/ ... repomd.xml: [Errno 14] HTTP Error 401: Authorization Required
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: asl-3.0. Please verify its path and try again


Its absolutely your credentials, I just installed ASL on a fresh C5 and C6 box using your username and password. Since you seem to be having so much trouble with your credentials, would you like me to install ASL for you?

If so, please follow the process at the URL below to provide us with access:

https://www.atomicorp.com/wiki/index.ph ... _system.3F

_________________
Michael Shinn
Atomicorp - Security For Everyone

Co-Author of Troubleshooting Linux Firewalls.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 22 posts ]  Go to page 1, 2  Next

» Feed - Atomicorp

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: Bing [Bot] and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group